ECN Electrical Forum - Discussion Forums for Electricians, Inspectors and Related Professionals
ECN Shout Chat
Top Posters(30 Days)
Trumpy 5
Recent Posts
What do you do?
by gfretwell. 09/24/17 12:05 PM
75 kva tranformer
by sparkync. 09/23/17 06:41 PM
Another generator question
by gfretwell. 09/23/17 04:15 PM
Supporting conduit bodies
by ghost307. 09/18/17 12:12 PM
Thermal Imaging Camera upgrade
by Potseal. 09/18/17 11:57 AM
New in the Gallery:
Gallery Test
Popular Topics(Views)
240,954 Are you busy
176,749 Re: Forum
168,598 Need opinion
Who's Online Now
0 registered members (), 42 guests, and 11 spiders.
Key: Admin, Global Mod, Mod
Previous Thread
Next Thread
Print Thread
Rate This Thread
Page 1 of 2 1 2
#218405 - 04/17/17 04:02 AM Linear Power Supply Quits Under Load  
Potseal  Offline
Member
Joined: Feb 2013
Posts: 239
Saskatchewan
I salvaged an old power supply from a piece of abandoned equipment. It is a linear power supply that is rated for 24VDC at 4.8A (http://www.mouser.com/ds/2/373/sl%20power_linears_ds-329280.pdf). I wanted to use it at work at my bench for occasionally testing various items. After adding a switch, indicator light (power "on"), alligator clip leads, and a fuse holder on the secondary of the 120VAC-24VDC transformer I tried powering on a 24VDC servo motor. Did not work. I disconnected the motor and measured the output voltage - 7VDC. Then I began the process of trying to figure out went wrong. This power supply uses a LM723 voltage regulator. I replaced the regulator, powered it "on", and then measured the output voltage - 24VDC. With the proper voltage I tried a load using a 20 ohm resistor. With a voltage meter attached I powered it "on" and the voltage immediately dropped from 24 to nearly 0 volts. Checked the 2A fuse and it had blown. Tried this again with a 150 Ohm resistor and it worked, fuse held. I checked the circuit board and I noticed a variable resistor connected to terminal #2 (current limit) on the LM723. Reading the specs it states:

"The LM723/LM723C is a voltage regulator designed primarily for series regulator applications. By itself, it will supply output currents up to 150 mA but external transistors can be added to provide any desired load current."

There are three 2N3055 power transistors in this circuit which I assume gives it the capability to output the 4.8A it is rated for. So is it possible that this adjustable current limit resistor is set to limit output current well below that? For some reason that doesn't make sense but everything else I have done to troubleshoot this issue has led nowhere. Any help is greatly appreciated. Thanks.


A malfunction at the junction
--------------------------------------
Dwayne

Tools for Electricians:

#218406 - 04/17/17 04:05 AM Re: Linear Power Supply Quits Under Load [Re: Potseal]  
Potseal  Offline
Member
Joined: Feb 2013
Posts: 239
Saskatchewan
[Linked Image]

The LM723 is at the upper left corner of the board with the adjustable current limit resistor to it's immediate right. The adjustment wheel was sealed with a dab of adhesive. I measured the resistance at 290 ohms then gently pried the adhesive off the resistor. It varies from 0 - 420 ohm. I wonder if it's adjusted at the factory to fine tune the circuit, sealed, and then shipped? Maybe my issue is the power transistors?

Last edited by Potseal; 04/17/17 04:14 AM.

A malfunction at the junction
--------------------------------------
Dwayne

#218408 - 04/17/17 05:55 AM Re: Linear Power Supply Quits Under Load [Re: Potseal]  
SteveFehr  Offline
Member
Joined: Mar 2005
Posts: 1,209
Chesapeake, VA
Could be. A lot of old low-end power supplies are designed with specific loads in mind and will not put out the right voltage if you test them open circuit or use them for something else with a higher load.


#218411 - 04/17/17 12:39 PM Re: Linear Power Supply Quits Under Load [Re: Potseal]  
Potseal  Offline
Member
Joined: Feb 2013
Posts: 239
Saskatchewan
Possibly.
The link above shows this item was once available through Mouser. The only thing it states in the specs is:
"Short Circuit Protection
Automatic current limit/foldback"

It looks like it was intended for general purpose use. IMO, it acts as though the power transistors are not in the circuit and current is limited by the LM723 alone which is 150mA.


A malfunction at the junction
--------------------------------------
Dwayne

#218413 - 04/17/17 03:59 PM Re: Linear Power Supply Quits Under Load [Re: Potseal]  
gfretwell  Offline


Member
Joined: Jul 2004
Posts: 9,118
Estero,Fl,usa
If the transistors are there, they are going to be using them but you might have bad one. Where is the 2a fuse, in the supply or the load? Do you have a scope? There may be a problem with the rectifier or filter that is putting AC or a bad ripple on the bulk DC to the regulator.
These things are really pretty simple devices. It looks like a center tapped transformer feeding 2 diodes, some filtering and the pass regulator.


Greg Fretwell

#218414 - 04/17/17 06:55 PM Re: Linear Power Supply Quits Under Load [Re: gfretwell]  
Potseal  Offline
Member
Joined: Feb 2013
Posts: 239
Saskatchewan
Originally Posted by gfretwell
If the transistors are there, they are going to be using them but you might have bad one. Where is the 2a fuse, in the supply or the load? Do you have a scope? There may be a problem with the rectifier or filter that is putting AC or a bad ripple on the bulk DC to the regulator.
These things are really pretty simple devices. It looks like a center tapped transformer feeding 2 diodes, some filtering and the pass regulator.


I removed the transistors and tested each one. Using a DMM set to ohms, positive lead to collector, negative lead to emitter which gave me O/L. Then I connected the base to the collector and it showed a high resistance reading.

Right now I'm testing all the caps...

The 2A fuse is on the secondary of the transformer and yes, I have an older analog scope.


A malfunction at the junction
--------------------------------------
Dwayne

#218415 - 04/17/17 07:00 PM Re: Linear Power Supply Quits Under Load [Re: Potseal]  
Potseal  Offline
Member
Joined: Feb 2013
Posts: 239
Saskatchewan
[Linked Image]


A malfunction at the junction
--------------------------------------
Dwayne

#218531 - 06/02/17 11:06 AM Re: Linear Power Supply Quits Under Load [Re: Potseal]  
emolatur  Offline
Member
Joined: Dec 2009
Posts: 14
Maine
You need more testing of those transistors. You've shown that they are capable of being "off" and that there is a BC junction, but have not tested the BE junction nor confirmed that they are capable of being "on."

The most likely layout (I can only guess, as I don't have a schematic) is that the output of the 723 goes to both 3055 bases, the 3055 collectors are connected to the "bulk dc" line, and the 3055 emitters each go through a low-ohm high-watt resistor (likely R13 and R15), the other ends of those resistors being connected to the output.

My guess is that either the 3055s are bad (failed open-circuit, ie, they never turn "on") OR they are not seeing sufficient DC on their collectors. I'm imagining that the 24V you DO see is being realized by the output of the 723 passing through the base/emitter junctions and resistors to reach the output. This means you're overloading the 723 (throwing it into current limit). Also, if the 723 were able to provide enough power, you'd end up further destroying the 3055s anyway.

My prescription is to replace both 2N3055s. They're dirt-cheap NPN BJTs. If the power supply is built the way I think it is, you should actually be able to substitute in just about any transistor having similar (or higher) power and voltage ratings. Before anybody questions me on that, I know the gain could sorta matter, but since the 3055 sucks so bad, anything modern is going to be the same or higher. smile


#218583 - 07/05/17 12:38 AM Re: Linear Power Supply Quits Under Load [Re: Potseal]  
JoeTestingEngr  Offline
Member
Joined: Nov 2005
Posts: 790
Chicago, Il.
If I recall, a 2N3055 can handle 15A on its own. It's the world's most common series pass transistor used in linear supplies. The beta, and in your use, the alpha, is relatively low. If your supply has 3, 1 is probably acting as a driver for the other 2, in a Darlington configuration. See if the bases of 2 are connected, and if the same 2 transistor's emitters, are connected through fractional ohm balancing resistors, to the output.

If you really had a DMM on ohms, instead of diode check, you would have read only read leakage. On diode check, you would get a slightly lower reading from base to collector, than base to emitter.

Frankly, if you were going to use a meter instead of a scope to troubleshoot, you started off on the wrong foot. Most of those units fail because their electrolytic capacitors dry out. Many of them derive a V++ supply with an extra diode and filter cap, to power the LM723. Don't go changing components until you've gone through with your DMM on AC Volts. More times than not, you'll find a substantial AC ripple voltage at 60 or 120Hz. If that isn't the problem, you could spot if the circuit is oscillating, not a good thing.

The current sensing will start coming into play when you get 0.6 or more volts between the output and current sense input, because you start biasing on the current limit transistor in the LM723. I don't have my datasheet open but the XX723, or sometimes 1723, has been around for decades, and is the most common regulator IC for linear supplies with external pass transistors.

The linear supply that I have to repair quite often is a +-15V, open frame, Lambda. It uses 2 LM723s, 2 2N3055s, and the separate V++ supply. The positive section is a straight forward design, with the emitter driving the output, and normal looking connections to the error amplifier. The negative output is not intuitive because the output is the negative supply rail, and the pass transistor connects to the common point. the error amplifier of the negative regulator is driven from a divider across both outputs, to make it "track" the positive regulator.
Joe


#218590 - 07/07/17 12:30 AM Re: Linear Power Supply Quits Under Load [Re: emolatur]  
Potseal  Offline
Member
Joined: Feb 2013
Posts: 239
Saskatchewan
Thank-you for the feedback Emolatur and Joe. This item has been sitting on my workbench too long. This weekend is already spoken for but holiday time looms ahead. Hopefully I can get to it sooner and next week I will try to make some progress. For something that looks so simple in design it's problem is not obvious to me.


A malfunction at the junction
--------------------------------------
Dwayne

Page 1 of 2 1 2

Member Spotlight
waymag
waymag
dallas, texas, USA
Posts: 67
Joined: January 2002
Show All Member Profiles 
Featured:

2017 Master Electrician Exam Preparation Combos
2017 NEC Electrician
Exam Prep Combos:
Master / Journeyman

 

Shout Box
Powered by UBB.threads™ PHP Forum Software 7.6.0
Page Time: 0.025s Queries: 16 (0.004s) Memory: 0.8252 MB (Peak: 1.0072 MB) Zlib enabled. Server Time: 2017-09-26 09:15:23 UTC